Seat Tarraco Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Has anyone else had this issue? We took the Tarraco away for a holiday last week, parked up for a day trip and when we returned a few hours later the touchscreen wouldn't work. The buttons along the left hand side (volume, power etc) would work but the touchscreen itself was completely non-responsive. This made it tricky as we couldn't fire up the satnav (in-built or Android Auto) to get us to our holiday park!

The issue has happened two more times since then. We think its the direct sunlight on the screen that is affecting it. I put a coat over the screen on our last day and that seemed to stop it getting too hot and playing up.

I don't know if this is a known fault. The screens on these cars are very large and shiny and get very warm to the touch. The screens on our Ateca are smaller, set back and matt finish so don't seem to get as hot.
 

·
Registered
Joined
·
295 Posts
nimdy said:
Has anyone else had this issue? We took the Tarraco away for a holiday last week, parked up for a day trip and when we returned a few hours later the touchscreen wouldn't work. The buttons along the left hand side (volume, power etc) would work but the touchscreen itself was completely non-responsive. This made it tricky as we couldn't fire up the satnav (in-built or Android Auto) to get us to our holiday park!

The issue has happened two more times since then. We think its the direct sunlight on the screen that is affecting it. I put a coat over the screen on our last day and that seemed to stop it getting too hot and playing up.

I don't know if this is a known fault. The screens on these cars are very large and shiny and get very warm to the touch. The screens on our Ateca are smaller, set back and matt finish so don't seem to get as hot.
Mine freezes like that every 5 starts of thereabouts and needs a hard reset (button pressed for 10-15 seconds until the SEAT logo appears) or it crashes and resets itself if I don't notice it after about 15 minutes.

The odd thing (well one of them at least) is that the radio keeps playing throughout but no other function is available other than the physical rotary buttons.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top