Seat Tarraco Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Having just taken delivery of my new Terraco I notice that the touch screen does not work with the lowest of the menu choices. For example: in the Vehicles Settings menu if you scroll down so that "Factory Settings" is in view when I touch it to open the sub-menu nothing happens. This issue shows up even if you scroll back up so that another choice is the lowest on the list. Its seems that only the second from the bottom works as regards the touch screen. This issue also shows up on other menus with the lowest item. I tried my wife's Arona and it works ok.
Has anyone noticed this issue?
I wonder is it a software issue or a faulty screen.
 

·
Registered
Joined
·
436 Posts
Could be faulty screen, try to hold the on/off button for as long as it takes to reboot the system and let it go once the SEAT logo pops up, report back on behaviour
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
stellamaris5 said:
Could be faulty screen, try to hold the on/off button for as long as it takes to reboot the system and let it go once the SEAT logo pops up, report back on behaviour
Hi, Thanks for suggestion. Tried the re-boot but it has not fixed the issue. I'll contact Dealer on Monday.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #4 ·
stellamaris5 said:
Could be faulty screen, try to hold the on/off button for as long as it takes to reboot the system and let it go once the SEAT logo pops up, report back on behaviour
I managed to get around the issue by opening the specific menu and using the right hand button (settings) on the LCD display. Turning the button runs up and down the menu choices and pushing it in picks the item and opens the next menu. Seems to work fine doing it this way as a work-round.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #6 ·
Have not been into Dealer since but will make the effort to get in this week. Ill let you know outcome.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #8 ·
stellamaris5 said:
JimC said:
Have not been into Dealer since but will make the effort to get in this week. Ill let you know outcome.
Any update on this? @JimC
I have been to Dealer and showed them the issue with the touch screen. I asked if they had anybody else with the same issue but they have not heard of this problem. My options are to take it into the Service Dept and have them look at it. My concern there is that some of the trim around the screen will have to be removed and I'm not sure how easy that will be without causing either some small damage or leave me with some rattles. I'm always concerned at factory fitted trim being removed so early into ownership. Things can have a habit of not going back as they were originally. As I can get round the issue using the right hand knob/button I think I'll live with it for now. I may speak to Service to see if a software update may help fix the issue but I have a feeling its the screen itself that has the issue. The screen on my wifes new Arona works perfectly.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #10 ·
bobbytoad said:
Is it the bottom of the display on all screens not responding or just on some screens?
It's the bottom line on all screens. As you will read above there is a work round using the right hand button so I'm going to live with it rather than have dash pulled apart to replace if a software reinstall does not fix.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #11 ·
Further to my last post. I've booked car into Dealer for them to have a look at ghe issue. The issue seems to fix itself under the following situations.
It can be ok when starting up but some time later on a journey the sceens seems to become unresponsive to touch. If screen is switched off and back on it sometimes clears the issue. At other times I have found that a reboot works. What is odd about the reboot is that when I first discovered the issue after getting the car the reboot didn't work. Initially it was the bottom line of the screen that was unresponsive to touch but now other areas become unresponsive. Odd. It all makes me wonder if there is a software issue that makes the screen unresponsive as when it does work the whole screen is ok for touch.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #12 ·
An Update: Car with Dealer this morning and I managed to show the Technician exactly what was happening with the screen as it was showing issue. Sometimes using the radio function the various option menus appear on the screen for no reason while driving. Odd but obviously part of the issue. The technician saw this happen when he took car into workshop. They phoned me a few minutes ago to say that the screen was checked and the 'focus touch points' during the test were jumping about all over the screen. They cleaned the screen (I didnt think it dirty when I left the car) and said that it seemed to fix the issue. They have left a microfibre cloth in the car for me to clean screen regularly. I will monitor the situation and let them know. If it recurs then they have said it may well be a new screen as they checked out the software side and all was ok.
 

·
Registered
Joined
·
174 Posts
Hope they don't expect you to wipe it after each time you touch it before they consider it a problem.

We don't see the tablet screens in McDonald's behaving that way. And God knows what's on them.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #14 ·
The Latest: screen no better after being to Dealer. Phoned Dealer today and they have ordered a new screen. Issue now is that new screen is on "back order" so no idea when it will turn up. Hopefully not too long.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #15 ·
New screen with Dealer, to be fitted Friday. Fingers crossed not issues and no new rattles.
 

·
Registered
Joined
·
174 Posts
JimC said:
New screen with Dealer, to be fitted Friday. Fingers crossed not issues and no new rattles.
Have they said if the dash need to be opened up for a screen change? Can understand your nervousness about rattles - it's my pet hate on any car. I've got a small one around the front passenger door/dash which I hope is just the door seal rubbing over bad road surfaces.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #18 ·
SizzlingPotato said:
JimC said:
New screen with Dealer, to be fitted Friday. Fingers crossed not issues and no new rattles.
Have they said if the dash need to be opened up for a screen change? Can understand your nervousness about rattles - it's my pet hate on any car. I've got a small one around the front passenger door/dash which I hope is just the door seal rubbing over bad road surfaces.
Nobody said how its installed as it was receptionist who phoned to say new screen had arrived. I was just hoping that its a case of taking the surrounding trim off and the screen pops out. Given most parts are just clipped I'm just hoping that there is a way of unclipping without breaking any clips. On saying that maybe there is more too it. Ill have a fair idea on how long they have the car as to how much time was involved. Looking forward to getting it fixed as the screen has a mind of its own just now, you can be driving along listening to a particular album when it decides to set it on repeat. You can't fix it while driving because you have to go through the menus manually. Once you've heard a tune five or six times it gets a bit of a pain.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #19 ·
Have had new screen fitted for a week or two now and seems to be working perfectly.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top